Locked out, some kind of hack?

Kelda Oen Lorax wrote...
I got some kind of hack last week where my inbox was filling up with 'undeliverable message' notices. I tried changing my password and when urraca (riseup bird) helped they recommend I change password again. Long story short, I'm still locked out, my password changes are not taking effect, and I noticed that at the bottom of the screen while I'm trying to log in, it sometimes says 'Waiting for mail.riseup.net' but also sometimes says 'Waiting for extension Wikibuy'.

What the heck? My password changes have never slowed the flow of these undeliverable messages, and now I can't DO anything. My alternate email is keldaoen@gmail.com (the only place I can reliably receive messages right now).
Thanks for any help!
Upvote | 0
Flag for Review
Kelda Oen Lorax replied...
I learned some stuff about browser extensions, and took out that spam-seeming-extension.
Re-set my password again. It's still not working and I'm still locked out :(
Upvote | 0
Flag for Review